在Android Froyo上启用Google Play的最小APK文件集

11次阅读
没有评论

问题描述

Android Froyo设备没有预装Google Play/Market或任何GAPPS,并且设备制造商不提供任何固件更新。用户想知道是否有可能在现在的情况下使Google Play/Market在Android Froyo上运行,并希望了解启用Google Play所需的最小.apk、framework和lib文件集。

解决方案

请注意以下操作注意版本差异及修改前做好备份。

方案

在Android Froyo上启用Google Play需要一些必要的.apk文件。以下是最小的.apk文件集,您可以将它们放置在相关文件夹中以启用Google Play。请注意,这里列出的.apk文件可能根据设备的不同而有所不同,但这是一个合理的最小集合。

  1. Vending.apk: 这是Google Play商店的主要应用程序。必须安装此应用程序以访问并下载其他应用。

  2. MarketUpdater.apk: 这个应用程序用于自动更新Google Play商店。虽然不是必需的,但建议安装以保持商店应用程序的最新版本。

  3. GoogleServicesFramework.apk: 这个应用程序提供Google服务的框架,是Google Play正常运行所必需的。

您可以通过以下几种方式获得这些.apk文件:

  • 从Google提供的合法来源下载。
  • 从已经安装了这些应用程序的设备中提取.apk文件。
  • 从第三方可信任的来源下载,确保文件不被篡改。

请注意,从非官方来源下载.apk文件存在一定的风险,因此请谨慎操作。

额外建议

如果您的设备已经获得root权限和自定义恢复,您还可以考虑直接从goo.im/gapps中刷入完整的GAPPS包。这将确保您获得所有Google服务和应用程序的最新版本,但可能占用更多的存储空间。

根据CyanogenMod wiki上的”Barebones”页面,您可以查看所需的.apk列表,而不是列出最小的.apk列表。这可以帮助您选择所需的应用程序来启用Google Play。至少,您需要Vending.apk和MarketUpdater.apk,可能还需要GoogleServicesFramework.apk。

注意:安装地图应用程序可能还是需要的,否则您可能无法访问有国家限制的应用程序。

希望这些信息能帮助您在Android Froyo上成功启用Google Play。如果您有任何进一步的问题,请随时提问。

正文完